Pazartesi , 20 Kasım 2017

C# Dizi Özellikler ve Metodları

C# dilinde tanımlanan dizilerde sıkça kullanılan bazı metod ve özellikleri ile bunların kullanımlarını aşağıdaki listede ve örneklerde inceleyebilirisiz. Özellik Açıklama Kullanımı Length Dizinin uzunluğunu getir. int dizi.Length Rank Dizinin  Kaç boyutlu olduğunu getir. int dizi.Rank   Metod Açıklama Kullanımı Sort Dizi içindeki elemanları sıralar. Array.Sort(dizi) GetValue İstenilen sıradaki dizi elemanını getir. dizi.GetValue(int indexno)  IndexOf Dizide aranan elemanın index numarasını getirir. Aranan eleman …

Devamını oku »

C# Metot Kullanarak Dizi Elemanlarını Toplama

C# Console Application ile Dizi içerisinde bulunan sayıları toplayan örnek uygulama: Örneğimizde “Topla” isimli metoda ana programdan parametre olarak dizi gönderilerek elemanların toplanması ve geri dönen değerin yazdırılması sağlanmıştır. C# Kodları: [crayon-5a123a2ce6e87751977658/] Beğendim! 4

Devamını oku »

Jquery Slider Eklentisi #Fotorama

Hemen hemen her sitede olmazsa olmazlardan birisidir sliderlar. Bu yazıda az kod(hiç javascript kodu yazmadan) bir slider nasıl oluşturulur onu anlatacağım. Kullanacağım slider eklentisi FOTORAMA; sliderı kullanmadan önce jquery kütüphanesi ve fotorama dosyalarını indirmelisiniz. Jquery      fotorama Dosyaları indirdikten sonra örnek bir html dosyası içine kütüphanemizi ve css dosyamızı çağırıyoruz. Unutmayın sitenizde jquery eklentisi kullanıyorsanız. Öncelikle jquery kütüphanesini yükleyin sonra …

Devamını oku »

İç İçe Eğer ile Hesaplama Örneği-2

YGS ve mülakat puanlarına göre BESYO’ ya öğrenci seçimi yapan excel program örneği Dosyayı indirmek için tıklayınız.orn_2 Girilen YGS puanına göre mülakat sınav sonuçlarını değerlendiriyoruz. Öncelikle Ön Kayıt sütununa YGS Puanı 230′ un altında olan öğrenciler için YGS Barajına Takıldınız”, üzeri puan alan öğrenciler için ise “Barajı Geçtiniz” yazsın. =EĞER(VE(D2=”Barajı Geçtiniz”;I2>=70);”BESYO’ lu Olmaya Hak Kazandınız”;”Seneye Tekrar Deneyebilirsiniz”) Bu hesaplama yapılırken …

Devamını oku »

C# Windows Form ile Yazılı Ortalaması Hesaplama

C# Windows Form ile 2 yazılı ve 1 sözlü notu girilerek Ortalamayı hesaplayıp Ekrana yazdırmak için oluşturulmuş uygulama örneği: Form tasarımımızı yukarıdaki şekilde ayarlıyoruz. Not girişleri için 3 adet textbox, 1 adet Button ve Label kontrollerimizi ekledikten sonra Button’ a çift tıklayarak; [crayon-5a123a2ce7790223574963/] uygulamamızı tamamlıyoruz. Beğendim!1

Devamını oku »

C# Console Örnekleri -3-

Taban ve yüksekliği bilinen bir üçgenin alanını hesaplama Pisagor teoremi ile Hipotenüs hesaplama Üçgende sinüs teoremi ile alan hesaplama Klavyeden girilen ikilik tabandaki bir sayının onluk tabandaki karşılığını yazdıran C# kodu Klavyeden girilen iki sayının bir birine bölünüp bölünmediğini gösteren C# Programı     Şu yazılar da ilginizi çekebilir C# Console Örnekleri 1 C# Console Örnekleri 2 C# Console Örnekleri …

Devamını oku »

İç İçe Eğer ile Not Hesaplama Örneği-1

Girilen sınav notlarının ortalamasını hesaplayıp, geçme/kalma durumlarını bildiren excel örneğini kaynak kodları ile birlikte incelebilirsiniz. Yazılı Ortalama Hesaplamak İçin Kullanılan Fonksiyon:  =ORTALAMA(B2;C2) Genel Ortalama Hesaplamak İçin Kullanılan Fonksiyon: =(E2*70%)+(D2*30%) Durum Bildirimi Yapmak İçin Kullanılan Fonksiyon:        =EĞER(F2<50;”kaldı”;”geçti”) Sayı ile Bildirim Yapmak İçin Kullanılan Fonksiyon: =EĞER(F2<50;”1″;EĞER(F2<55;”2″;EĞER(F2<70;”3″;EĞER(F2<85;”4″;”5″)))) Yazı ile Bildirim Yapmak İçin Kullanılan Fonksiyon: =EĞER(F2<50;”Bir”;EĞER(F2<55;”İki”;EĞER(F2<70;”Üç”;EĞER(F2<85;”Dört”;”Beş”)))) Beğendim!

Devamını oku »

C# Console Sayı Tahmin Oyunu

C# Console Applicationda yapılmış Sayı Tahmin Oyunu. Programda Rasgele 0-100 arası tutulan sayıyı kullanıcının tahmin etmesi isteniyor. Girdiği sayıya göre gerekli yönlendirmeler yapılarak sonuçta kaçıncı hakta tutulan sayıya ulaşıldığı ekranda gösteriliyor. [crayon-5a123a2ce809f232785395/] Beğendim!

Devamını oku »

C# Console Beep Kullanım

Console.Beep ile bilgisayarın hopörleründen 37- 32767 hertz arasındaki değişen sesleri duyabiliriz. Console.Beep kullanımı: Console.Beep(int frekans,int sure) şeklindedir. frekans 37-32767 aralığındaki sayılar, süre ise bu sesin ne kadar duyulacağını ifade eder. Aşağıda örnek uygulamayı çalıştırmak için using kısmına using System.Threading; bekleme için gerekli olan isim alanını(interface) eklemeyi unutmayın.   [crayon-5a123a2ce8319399498734/]       Beğendim!

Devamını oku »

C# Klavyeden Girilen Ünlü Karakter Mi?

Klavyeden girilen karakterin sesli karater olup olmadığını bulanan program;   Şartımızda sesli karaterleri yada(veya ||) operatörü ile ekliyoruz.  Girdiğimiz karater şart içinde(if)  sesli karakterlerden biri  ile eşleştiğinde şart true olacak ve girdiğiniz karakter sesli karakterdir yazacaktır. cha [crayon-5a123a2ce859a522168177/]   dKey(); Beğendim!

Devamını oku »

C# For Döngüsü Karışık Örnekler -1-

for döngüsü c#

C# Console Uygulamasında yapılmış karışık For Döngüsü Örnekleri: Şu yazılar da ilginizi çekebilir C# Console Örnekleri 1 C# Console Örnekleri 2 C# Console Örnekleri 3 C# If Else Örnekleri C# For Örnekleri 1 C# For Örnekleri 2 C# While Örnekleri C# Dizi Örnekleri C# Foreach Örnekleri 1-100 arası 3′ e ve 5’e tam bölünebilen sayıları listeleyen Console Örneği: [crayon-5a123a2ce8a21332634698/] 1-100 …

Devamını oku »

Javascript: keypress klavye kontrolü

Javascript ile keypress olay kontrolü ile ekranki div etiketini yön tuşları ile istediğimiz yöne hareket ettiren program kodu; Klavye kontrollerinin çalışmasını anlatmadan önce css ile nesnenin hareket edebilmesi için position özelliğinin absolute yapıldığına dikkat edin. Örnek üç temel parçadan oluşmaktadır. 1.kısım nesnenin css kodu 2.kısım nesnemizin tanımlanması.(javascript kodunu sayfanın sonuna eklediğinizden emin olun) 3. javascript kodumuz. Klavyedeki yön tuşlarının kod …

Devamını oku »

C# Console % (Mod) Örneği

C# Console Uygulamasında Kullanıcıdan 2 tane sayı istenerek 1. sayının 2. sayıya tam bölünmesi durumunda “Tam bölünüyor” yazan, aksi durumda Tam bölünmüyor diyerek kalanı ekranda gösteren örnek: [crayon-5a123a2ce9544306316445/] Beğendim!

Devamını oku »

C# Console Ehliyet – Yaş Hesaplama

C# Console Uygumasında kullanıcıdan yaş bilgisi istenerek eğer yaşı 18 ve daha büyükse “Ehliyet Alabilirsiniz” yazan,değilse Ehliyet alamazsınız diyerek Ehliyet alabilmesi için kaç yılı kaldığını ekranda gösteren örnek: [crayon-5a123a2ce974a626272362/] Beğendim!2

Devamını oku »

C# Tarih Formatlama

C# programlama dilinde ekranda tarihi istenilen formatta yazmak mümkündür. Tarih formatlama işleminin nasıl yapıldığını gösteren Console Uygulaması:   Şimdi yukarıdaki tabloya göre kodlarımızı oluşturalım. [crayon-5a123a2ce9949284120387/] Ekran çıktısı: Beğendim!

Devamını oku »

Arduino Led Yakıp Söndürme

    Port ve cihaz ayarlamadan sonra arduinonun iki temel metodunun kullanımını açıklayalım. setup():Giriş çıkış pinlerinin belirlendiği metodtur. loop(): adından da anlaşıldığı gibi program çalıştığında tekrar tekrar çalışacak metodu ifade ediyor. arduino ile yapmak istediğimiz kontrolleri yani program kodlarını yazacağımız kısımdır. Arduino ile yazılacak en basit uygulama bir ledi yakıp söndürmedi olsa gerek. Bu işlem için bir tane Led, Ledin …

Devamını oku »